[SOLVED] Add unicode support for webpart.

Here we can discuss suggestions and development of amxbans.
Nothing discussed in here are certain that it will be coded or added.
sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

[SOLVED] Add unicode support for webpart.

Postby sami1 » 02 Aug 2013, 13:39

Hello .

I've seen lately that Valve have updated their steam pipes of HLDs and stuff.
We must use STEAMCMD now..

anyways, amxbans is working great with it.
The plugin part is all good, except for the web files part.

Now, since valve updated HLDS, we can change our names to anything and any style, and any language, also with designed names
example: sαмɪ


so, my name in the server is sαмɪ and its all good..

But, when I ban someone, the name will not show sαмɪ

it will be like:

Image
Attachments
picc.png
picc.png (5.09 KiB) Viewed 8610 times

YamiKaitou
Amxbans Developer
Posts: 257
Joined: 17 Apr 2013, 14:09

Re: Add unicode support for webpart.

Postby YamiKaitou » 02 Aug 2013, 16:30

Are you sure it is an issue with the Web part? What charset is your SQL database using? Is it only the usernames that aren't being formated correctly?

sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Postby sami1 » 02 Aug 2013, 19:16

So, I banned myself and i got this.

Image

Image



YamiKaitou wrote: What charset is your SQL database using?


Do you mean this 1?

Image
if yes, then I'm using the default 1 =>utf8_general_ci

YamiKaitou wrote: Are you sure it is an issue with the Web part?


I think its either from the web files, or something is wrong with my phpmyadmin.




YamiKaitou wrote: Is it only the usernames that aren't being formated correctly?

No.

The banned user, the admin who banned, and the reason for getting banned will look like that.

Code: Select all

ﻱﺮﻤﺸﻟïºÂ







-
Attachments
charset.png
charset.png (19.41 KiB) Viewed 8607 times
demo.png
demo.png (4.9 KiB) Viewed 8607 times
demo 2.jpg
demo 2.jpg (36.17 KiB) Viewed 8607 times

Zapy
Site Admin
Posts: 121
Joined: 01 Apr 2013, 15:52

Re: Add unicode support for webpart.

Postby Zapy » 02 Aug 2013, 20:03

mysql, php and web-server version?

i actually just noticed this my self on my community, only thing we have changed is upgrade from mysql 5.5 to 5.6
Ill look in to this with a VM server but i think ill need some help from Yami.
Project Leader for Amxbans.net from 2013
Head Community admin for Warzone Short Valley
Swedish Gaming Community since 2000
www.warzone.nu

sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Postby sami1 » 02 Aug 2013, 20:14

Image
Attachments
Untitled.png
Untitled.png (8.55 KiB) Viewed 8602 times

YamiKaitou
Amxbans Developer
Posts: 257
Joined: 17 Apr 2013, 14:09

Re: Add unicode support for webpart.

Postby YamiKaitou » 02 Aug 2013, 21:36

Can you log this as an Issue on the Repository so I remember to look into it deeper?

sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Postby sami1 » 02 Aug 2013, 23:26

Thank you guys for your support!

I ill be waiting for the fix.

EDIT: EDIT: EDIT: EDIT: EDIT :mrgreen:

I was looking in the web files for 2 hours and testing, and i saw this .

amxbans folder/language/lang.english.php


Code: Select all

<?php
//encoding and locale
define("_ENCODING","ISO-8859-1"); //ISO-8859-1,utf-8
define("_LOCALE","en_EN"); //de_DE,fr_FR,en_EN...



is the encoding correct?


Return to “Development and Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest