Page 1 of 2

Recommended MySQL Version?! For AMXBANS!

Posted: 16 Jul 2014, 00:56
by mrkiller2010
So my MySQL database is so weird, keeps disconnecting and crash all the time.
What is the best MySQL database you can have? For AMXBANS

Currently I have: Image

Do I need to tell the webhost to update or something?
Because these sucks, It's a really big delay between the server and the datebase.
Some times it doesn't even connect.

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 16 Jul 2014, 03:35
by YamiKaitou
I haven't noticed an issue with this version

Code: Select all

mysql> SHOW VARIABLES LIKE "%version%";
+-------------------------+------------------------------+
| Variable_name           | Value                        |
+-------------------------+------------------------------+
| innodb_version          | 5.5.37                       |
| protocol_version        | 10                           |
| slave_type_conversions  |                              |
| version                 | 5.5.37-cll                   |
| version_comment         | MySQL Community Server (GPL) |
| version_compile_machine | x86_64                       |
| version_compile_os      | Linux                        |
+-------------------------+------------------------------+
7 rows in set (0.00 sec)



What are the exact errors you are having?

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 16 Jul 2014, 16:06
by mrkiller2010
[QUOTE=YamiKaitou;2168427]I actually never stop developing it since I took it over, just put it on hold and only worked on supporting the current code.

Also, I haven't noticed an issue with this version

Code: Select all

mysql> SHOW VARIABLES LIKE "%version%";
+-------------------------+------------------------------+
| Variable_name           | Value                        |
+-------------------------+------------------------------+
| innodb_version          | 5.5.37                       |
| protocol_version        | 10                           |
| slave_type_conversions  |                              |
| version                 | 5.5.37-cll                   |
| version_comment         | MySQL Community Server (GPL) |
| version_compile_machine | x86_64                       |
| version_compile_os      | Linux                        |
+-------------------------+------------------------------+
7 rows in set (0.00 sec)
[/QUOTE]

The connection is bad I think..
What the problem for me is that sometimes the database doesn't work so /amxbans says "Connection to the datebase is required" (not exactly that error but kind of that error) And that happends, everyone that is banned can join the server.

And we can't ban anyone neither.

Image

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 17 Jul 2014, 07:26
by YamiKaitou
I need the exact error

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 17 Jul 2014, 20:11
by mrkiller2010
There is no error. The connection with this datebase and the server is slow.
And why is there a ! red mark on the amx site?

Can't you check if there is anything that you can optimze?

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 17 Jul 2014, 22:21
by YamiKaitou
mrkiller2010 wrote:There is no error. The connection with this datebase and the server is slow.

Is it slow only on the website or also for the game server?

And why is there a ! red mark on the amx site?

I don't know where that image is from.

Can't you check if there is anything that you can optimze?

Is the SQL host on the same machine as the site?

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 17 Jul 2014, 23:53
by mrkiller2010
Image

It's the same hosting comapny www.citynetwork.se I don't know if it's on the same machine.

And I talked to them, They said it was the latest version of MySQL For solaris11.

The ban doesn't connect to the site sometimes.
I mean the connection lose sometimes.
On the /amxbans.php it says Connection to database lost
and in the server once you ban someone nothing happens.

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 18 Jul 2014, 02:13
by YamiKaitou
In your config, are you using localhost or something else?

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 18 Jul 2014, 11:15
by mrkiller2010
I use: amx_sql_host "mysql12.citynetwork.se"

using localhost:

[AMXBans] No Reasons found in Database. Static reasons were loaded instead.
L 07/18/2014 - 11:14:53: [amxbans_main.amxx] [AMXBans] No Reasons found in Database. Static reasons were loaded instead.
L 07/18/2014 - 11:14:53: [amxbans_main.amxx] [AMXBans] Connection failed!
L 07/18/2014 - 11:14:53: [amxbans_main.amxx] [AMXBans] Threaded Query Error, Place: 17
L 07/18/2014 - 11:14:53: [amxbans_main.amxx] [AMXBans] Message: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (2002)
L 07/18/2014 - 11:14:53: [amxbans_main.amxx] [AMXBans] Query statement:

Re: Recommended MySQL Version?! For AMXBANS!

Posted: 18 Jul 2014, 12:30
by YamiKaitou
Unless your Game Server and SQL server are on the same machine, do not use localhost.

My question was related to your Web Host