Click not working in admin area section

Ask questions about errors and problems related to the amxbans project.
The more details you give, the better answer you will receive, READ the sticky topics before posting!

Be sure to post in the right sub forum: Bugs and Security
pawangond
Posts: 12
Joined: 22 Jan 2017, 16:30
Location: India

Click not working in admin area section

Post by pawangond »

I am unable to switch between Admin area / Server / website / others / modules

actually i am unable to click options only else everythig is working fine, on mobile its all working fine just not working on pc browsers tried firefox , chrome and even IE :roll:

Server info :

AMXBans Website Version 6.14.4
Webserver Apache
PHP Version 5.6.32
MySQL Version 5.6.37
safe_mode off
register_globals off
magic_quotes_gpc off
display_errors off
post_max_size 64M (67108864 bytes)
upload_max_filesize 64M (67108864 bytes)
max_execution_time 90

PHP module
bcmath yes
gmp yes
GD yes (bundled (2.1.0 compatible))
Image
User avatar
indianiso1
Posts: 169
Joined: 16 Oct 2015, 01:59
Contact:

Re: Click not working in admin area section

Post by indianiso1 »

Try to re-paste files.
pawangond
Posts: 12
Joined: 22 Jan 2017, 16:30
Location: India

Re: Click not working in admin area section

Post by pawangond »

Which files ? All files ?
Image
hardboy
Posts: 13
Joined: 30 Dec 2014, 15:47

Re: Click not working in admin area section

Post by hardboy »

Not Fixed
User avatar
indianiso1
Posts: 169
Joined: 16 Oct 2015, 01:59
Contact:

Re: Click not working in admin area section

Post by indianiso1 »

Try to login in the system.
Then open http://domain.to/amxbans/[b]templates/_ ... ans.js.php[/b] and check if you have non-empty file, starting like:

Code: Select all

function LiveBanCopyVars (name,steamid,ip,userid) {
...
If it's empty please write below..
hardboy
Posts: 13
Joined: 30 Dec 2014, 15:47

Re: Click not working in admin area section

Post by hardboy »

Test Version 6.13 & 6.14.4

Code: Select all

<?php session_start(); if(@$_SESSION["loggedin"]) { ?>

function LiveBanCopyVars (name,steamid,ip,userid) {

	document.getElementById('player_name').value = name;

	document.getElementById('player_uid').value = userid;

	document.getElementById('player_steamid').value = steamid;

	document.getElementById('player_ip').value = ip;

}



function SetNewPassword(fieldid,lang1,lang2,notmatch) {

	var pw1 = window.prompt(lang1, '');

	if(!pw1) return false;

	

	var pw2 = window.prompt(lang2, '');

	if(pw1 != pw2) { 

		alert(notmatch);

		return false;

	} else {

		document.getElementById(fieldid).value = pw1;

		return true;

	}

}



function ToggleMenu_open(obj) {

	if(obj != 1) { ToggleMenu_close('1'); }

	if(obj != 2) { ToggleMenu_close('2'); }

	if(obj != 3) { ToggleMenu_close('3'); }

	if(obj != 4) { ToggleMenu_close('4'); }

	if(obj != 5) { ToggleMenu_close('5'); }



	if(document.getElementById('menu_'+obj).style.display == 'none') {

		document.getElementById('menu_'+obj).style.display = 'block';

	}

}



function ToggleMenu_close(obj) {

	if(document.getElementById('menu_'+obj).style.display == 'block') {

		document.getElementById('menu_'+obj).style.display = 'none';

	}

}



<?php } ?>

function ToggleLayer(obj) {

	if(document.all) {

		if(document.all[obj].style.display == 'none') {

			document.all[obj].style.display = 'block';

		} else {

			document.all[obj].style.display = 'none';

		}

	} else {

		if(document.getElementById(obj).style.display == 'none') {

			if(document.getElementById(obj).tagName == 'DIV') {

				document.getElementById(obj).style.display = 'block';

			} else {

				document.getElementById(obj).style.display = 'table-row';

			}

		} else {

			document.getElementById(obj).style.display = 'none';

		}

	}

}



function NewToggleLayer(element) {

	var e = $('#' + element);

	if (e.css('display') == 'none') {

		e.show().find('div').slideDown('slow')

	} else {

		 e.find('div').slideUp('slow', function() { $(this).parent().parent().hide(); })

	}

}
All its fine.. maybe php have trouble? i m tested with 5.6 and 7.0 and nothing to do
User avatar
indianiso1
Posts: 169
Joined: 16 Oct 2015, 01:59
Contact:

Re: Click not working in admin area section

Post by indianiso1 »

Open in browser...
Infamous2019
Posts: 6
Joined: 12 Jul 2019, 20:55

Re: Click not working in admin area section

Post by Infamous2019 »

No Fix avaible ? I have the self problem !
User avatar
indianiso1
Posts: 169
Joined: 16 Oct 2015, 01:59
Contact:

Re: Click not working in admin area section

Post by indianiso1 »

No. Newest version still in development. But that will only support PHP7+
Infamous2019
Posts: 6
Joined: 12 Jul 2019, 20:55

Re: Click not working in admin area section

Post by Infamous2019 »

19 Sep 2017 was the last release, why it need more time as 2 years?!
Post Reply