Problem with AmxBans

Ask questions about errors and problems related to the amxbans project.
The more details you give, the better answer you will receive, READ the sticky topics before posting!

Be sure to post in the right sub forum: Bugs and Security
thescaryguy
Posts: 13
Joined: 19 Feb 2020, 20:37

Problem with AmxBans

Postby thescaryguy » 20 Feb 2020, 23:35

I am getting this problem when trying to set up AmxBans:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; dynamicPage has a deprecated constructor in /home4/thescaryguy/public_html/amxbans/setup.php on line 80

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home4/thescaryguy/public_html/amxbans/setup.php:80) in /home4/thescaryguy/public_html/amxbans/setup.php on line 23

Warning: Creating default object from empty value in /home4/thescaryguy/public_html/amxbans/setup.php on line 33

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Smarty has a deprecated constructor in /home4/thescaryguy/public_html/amxbans/include/smarty/Smarty.class.php on line 64

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Smarty_Compiler has a deprecated constructor in /home4/thescaryguy/public_html/amxbans/include/smarty/Smarty_Compiler.class.php on line 35

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /home4/thescaryguy/public_html/amxbans/include/smarty/Smarty_Compiler.class.php on line 270


Trying to get AmxBans to work. Any suggestions are welcome. Thanks in advance.

User avatar
indianiso1
Posts: 153
Joined: 16 Oct 2015, 01:59
Contact:

Re: Problem with AmxBans

Postby indianiso1 » 21 Feb 2020, 10:36

PHP version?
amxbans version?

thescaryguy
Posts: 13
Joined: 19 Feb 2020, 20:37

Re: Problem with AmxBans

Postby thescaryguy » 22 Feb 2020, 15:53

amxbans_version 6.13
amxmodx_version 1.8.3-dev
amx_client_languages 1
amx_tk_subtract_kills_stats v1.3 - by diamond-optic (http://www.AvaMods.com)
dod_tk_nodeath_stats 1.0
metamod_version 1.21p37

php version 7

User avatar
indianiso1
Posts: 153
Joined: 16 Oct 2015, 01:59
Contact:

Re: Problem with AmxBans

Postby indianiso1 » 23 Feb 2020, 19:10

AMXBans v6.13 is not supported by php 7

thescaryguy
Posts: 13
Joined: 19 Feb 2020, 20:37

Re: Problem with AmxBans

Postby thescaryguy » 24 Feb 2020, 11:03

indianiso1 wrote:AMXBans v6.13 is not supported by php 7


Thank you for your help :)


Return to “Support and Help”

Who is online

Users browsing this forum: MSN [Bot] and 1 guest