[SOLVED] Add unicode support for webpart.

Here we can discuss suggestions and development of amxbans.
Nothing discussed in here are certain that it will be coded or added.
Post Reply
sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

[SOLVED] Add unicode support for webpart.

Post by sami1 »

Hello .

I've seen lately that Valve have updated their steam pipes of HLDs and stuff.
We must use STEAMCMD now..

anyways, amxbans is working great with it.
The plugin part is all good, except for the web files part.

Now, since valve updated HLDS, we can change our names to anything and any style, and any language, also with designed names
example: sαмɪ


so, my name in the server is sαмɪ and its all good..

But, when I ban someone, the name will not show sαмɪ

it will be like:

Image
Attachments
picc.png
picc.png (5.09 KiB) Viewed 15645 times
YamiKaitou
Amxbans Developer
Posts: 257
Joined: 17 Apr 2013, 14:09

Re: Add unicode support for webpart.

Post by YamiKaitou »

Are you sure it is an issue with the Web part? What charset is your SQL database using? Is it only the usernames that aren't being formated correctly?
Retired, don't bug me
sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Post by sami1 »

So, I banned myself and i got this.

Image

Image


YamiKaitou wrote: What charset is your SQL database using?
Do you mean this 1?

Image
if yes, then I'm using the default 1 =>utf8_general_ci
YamiKaitou wrote: Are you sure it is an issue with the Web part?
I think its either from the web files, or something is wrong with my phpmyadmin.



YamiKaitou wrote: Is it only the usernames that aren't being formated correctly?
No.

The banned user, the admin who banned, and the reason for getting banned will look like that.

Code: Select all

ﻱﺮﻤﺸﻟïºÂ





-
Attachments
charset.png
charset.png (19.41 KiB) Viewed 15642 times
demo.png
demo.png (4.9 KiB) Viewed 15642 times
demo 2.jpg
demo 2.jpg (36.17 KiB) Viewed 15642 times
Zapy
Site Admin
Posts: 122
Joined: 01 Apr 2013, 15:52

Re: Add unicode support for webpart.

Post by Zapy »

mysql, php and web-server version?

i actually just noticed this my self on my community, only thing we have changed is upgrade from mysql 5.5 to 5.6
Ill look in to this with a VM server but i think ill need some help from Yami.
Project Leader for Amxbans.net from 2013
Head Community admin for Warzone Short Valley
Swedish Gaming Community since 2000
www.warzone.nu
sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Post by sami1 »

Image
Attachments
Untitled.png
Untitled.png (8.55 KiB) Viewed 15637 times
YamiKaitou
Amxbans Developer
Posts: 257
Joined: 17 Apr 2013, 14:09

Re: Add unicode support for webpart.

Post by YamiKaitou »

Can you log this as an Issue on the Repository so I remember to look into it deeper?
Retired, don't bug me
sami1
Posts: 53
Joined: 18 Jul 2013, 21:28

Re: Add unicode support for webpart.

Post by sami1 »

Thank you guys for your support!

I ill be waiting for the fix.

EDIT: EDIT: EDIT: EDIT: EDIT :mrgreen:

I was looking in the web files for 2 hours and testing, and i saw this .

amxbans folder/language/lang.english.php

Code: Select all

<?php
//encoding and locale
define("_ENCODING","ISO-8859-1"); //ISO-8859-1,utf-8
define("_LOCALE","en_EN"); //de_DE,fr_FR,en_EN...

is the encoding correct?
Post Reply